Google is investigating reports of an issue with Google Drive
Incident Report for JBIT.com systems
Resolved
Google has advised the problem with Google Drive should be resolved.
Posted over 2 years ago. May 19, 2015 - 15:06 CDT
Monitoring
Google Drive service has already been restored for some users, and Google expects a resolution for all users within the next 1 hour. Please note this time frame is an estimate and may change.
Posted over 2 years ago. May 19, 2015 - 13:34 CDT
Investigating
Accessing shared folders in Google Drive fails intermittently with error: "The open folder can no longer be viewed".

Google is investigating.

http://www.google.com/appsstatus
Posted over 2 years ago. May 19, 2015 - 12:24 CDT