Google is reporting issues with multiple G Suite services
Incident Report for JBIT.com systems
Resolved
We have received notification from Google that this issue is resolved. Please see https://www.google.com/appsstatus for confirmation from Google.

We are marking this incident as resolved in our Status Page. Automated Google disruption updates on our Status Page home page may continue for a while, until they send the all clear.
Posted 2 months ago. Sep 12, 2017 - 11:35 CDT
Identified
Google Engineering has identified a potential root cause to the issue and is implementing a fix. https://www.google.com/appsstatus

We will post more when we have it.
Posted 2 months ago. Sep 12, 2017 - 11:30 CDT
Investigating
Google is reporting issues with multiple G Suite services. Please see https://www.google.com/appsstatus for up-to-date info.

We will post further updates when we know more.
Posted 2 months ago. Sep 12, 2017 - 11:23 CDT