Google Drive
Incident Report for JBIT.com systems
Resolved
Google advises Drive service has already been restored for some users, and they expect a resolution for all users in the near future.
Posted about 2 years ago. Nov 04, 2015 - 22:41 CST
Investigating
Google is experiencing an issue affecting less than an estimated 3% of the Google Drive user base. The affected users are unable to access Google Drive.

We will provide more information as soon as we are able.
Posted about 2 years ago. Nov 04, 2015 - 22:16 CST