Google is investigating reports of an issue with Gmail
Incident Report for JBIT.com systems
Resolved
Google advises the problem with Gmail delivery delays should be resolved now for all users.
Posted over 2 years ago. Jun 09, 2015 - 14:47 CDT
Monitoring
Google advises Gmail service has already been restored for some users, and they expect a resolution for all users in the near future.

Please note this time frame is an estimate and may change.

A subset of messages is still being delivered by Google's servers.

http://www.google.com/appsstatus
Posted over 2 years ago. Jun 09, 2015 - 14:11 CDT
Investigating
Google is investigating reports of an issue with Gmail. They will provide more information shortly.

http://www.google.com/appsstatus
Posted over 2 years ago. Jun 09, 2015 - 13:52 CDT