JBIT Support help desk (support.jbit.com)
Incident Report for JBIT.com systems
Resolved
Clear event for JBIT Support help desk (support.jbit.com); HTTP - JBIT Support (support.jbit.com): Infinite redirect loop
Posted over 2 years ago. Jun 01, 2015 - 11:05 CDT
Identified
Outage event for JBIT Support help desk (support.jbit.com); HTTP - JBIT Support (support.jbit.com): Infinite redirect loop
Posted over 2 years ago. Jun 01, 2015 - 06:45 CDT