Google is investigating reports of an issue with Google Calendar
Incident Report for JBIT.com systems
Resolved
Google Calendar service has already been restored for some users, and we expect a resolution for all users in the near future. Please note this time frame is an estimate and may change.
Posted over 2 years ago. May 27, 2015 - 19:58 CDT
Update
Google is continuing to investigate this issue. They will provide an update by May 27, 2015 3:07:00 PM PDT with more information about this problem.

http://www.google.com/appsstatus#hl=en&v=issue&sid=2&iid=497cc160b4385dc4db87bb02242c9aff
Posted over 2 years ago. May 27, 2015 - 14:20 CDT
Update
Google is continuing to investigate this issue. They will provide an update by May 27, 2015 12:01:00 PM PDT with more information about this problem.

http://www.google.com/appsstatus#hl=en&v=issue&sid=2&iid=497cc160b4385dc4db87bb02242c9aff
Posted over 2 years ago. May 27, 2015 - 11:18 CDT
Investigating
Google is investigating reports of an issue with Google Calendar.
http://www.google.com/appsstatus#hl=en&v=issue&sid=2&iid=497cc160b4385dc4db87bb02242c9aff

Currently, we are not aware of any JBIT customers experiencing issues with Google Calendar.

We will update this when we know more.
Posted over 2 years ago. May 27, 2015 - 09:45 CDT