Google is investigating reports of an issue with Google Drive.
Incident Report for JBIT.com systems
Resolved
Google advises Drive service has already been restored for some users, and they expect a resolution for all users within the next 1 hour. Please note, they advise this time frame is an estimate and may change.
Posted over 1 year ago. Apr 04, 2016 - 11:18 CDT
Investigating
Google is investigating reports of an issue with Google Drive.

Affected users can not edit folders they own within Google Drive.

We will provide further updates as soon as we receive them.

Google Apps Status Updates - https://www.google.com/appsstatus
Posted over 1 year ago. Apr 04, 2016 - 11:14 CDT