support.jbit.com
Incident Report for [JBIT Status]
Resolved
Clear event for support.jbit.com; HTTP (Secure) (support.jbit.com)
Posted Apr 12, 2019 - 09:02 CDT
Identified
Outage event for support.jbit.com; HTTP (Secure) (support.jbit.com)
Posted Apr 12, 2019 - 08:58 CDT