Google is investigating issues with Google Drive
Incident Report for [JBIT Status]
Resolved
Google is reporting this issue is now resolved.
Posted Oct 27, 2014 - 16:16 CDT
Investigating
Google is investigating issues with Google Drive. "We're investigating reports of an issue with Google Drive. We will provide more information shortly. Affected users will notice 500 errors and latency."

Updates at http://www.google.com/appsstatus
Posted Oct 27, 2014 - 11:06 CDT