Google Apps - Google Drive issues
Incident Report for [JBIT Status]
Resolved
Google advises this issue is now resolved for all users.
Posted Jun 04, 2014 - 12:14 CDT
Monitoring
Google is reporting issues for some users of Google Drive. Issues include slowness, latency issues, and receiving 500 errors when accessing Drive.

Please check the Google Apps Status Dashboard for further information.
http://www.google.com/appsstatus
Posted Jun 04, 2014 - 10:49 CDT