Google Apps - Google Calendar issues
Incident Report for [JBIT Status]
Resolved
Google has advised the problem with Google Calendar should be resolved for all users.

www.google.com/appsstatus
Posted Jun 18, 2014 - 16:07 CDT
Update
Google is reporting service is restored for some users and they are working on restoring for all.

www.google.com/appsstatus
Posted Jun 18, 2014 - 15:37 CDT
Monitoring
Google is investigating reports of an issue with Google Calendar.

http://www.google.com/appsstatus
Posted Jun 18, 2014 - 14:42 CDT