Google Meet status alert
Incident Report for JBIT.com Houston, TX Systems
Resolved
This incident has been resolved.
Posted Oct 28, 2021 - 01:57 CDT
Monitoring
Further update from Google:
Google Meet service has already been restored for some users, and we expect a resolution for all users in the near future. Please note this time frame is an estimate and may change.
Posted Oct 27, 2021 - 22:20 CDT
Update
Further update from Google:
Our team is continuing to investigate this issue. We will provide an update by Oct 28, 2021, 3:00 AM UTC with more information about this problem. Thank you for your patience.
Posted Oct 27, 2021 - 20:00 CDT
Update
Further update from Google:
Our team is continuing to investigate this issue. We will provide an update by Oct 28, 2021, 1:00 AM UTC with more information about this problem. Thank you for your patience.
Posted Oct 27, 2021 - 17:09 CDT
Update
Google advises:
We are continuing to investigate this issue. We will provide an update by Oct 27, 2021, 10:00 PM UTC detailing when we expect to resolve the problem.
Posted Oct 27, 2021 - 14:11 CDT
Update
Google continues to provide updates:
Google Meet users may experience latency and/or buffering while viewing livestream events.
Posted Oct 27, 2021 - 12:25 CDT
Identified
Google advises:
The affected users are able to access Google Meet, but are seeing error messages, high latency, and/or other unexpected behavior.
Livestream users are seeing increased latency and buffering.
Posted Oct 27, 2021 - 12:19 CDT
Investigating
Google advises:

This Apps outage alert is to inform you of a Google Workspace issue affecting some of the supported services.

The alert details include:

Status: New
Affected service(s): Google Meet
Summary: We're investigating reports of an issue with Google Meet. We will provide more information shortly.
Next update estimate: Wednesday, Oct 27, 2021 5:49:00 PM (UTC).
Posted Oct 27, 2021 - 12:13 CDT
This incident affected: Google Workspace (Meet).