support.jbit.com
Incident Report for JBIT.com Houston, TX Systems
Resolved
Clear event for support.jbit.com; HTTPS - JBIT.com Support Desk web portal [support.jbit.com] (support.jbit.com): HTTPS session timed out during read
Posted Jun 21, 2022 - 02:37 CDT
Identified
Outage event for support.jbit.com; HTTPS - JBIT.com Support Desk web portal [support.jbit.com] (support.jbit.com): HTTPS session timed out during read
Posted Jun 21, 2022 - 01:35 CDT