Our help desk continues to have availability issues
Incident Report for [JBIT Status]
Resolved
Zendesk advises this is resolved. https://twitter.com/ZendeskOps/status/558344255790264321

The site has been fully available since.

This issue is now resolved.
Posted Jan 22, 2015 - 15:34 CST
Identified
Yesterday's issue with support.jbit.com is continuing. Our online help desk continues to be unavailable.

Zendesk is aware and is working on the issue. https://support.zendesk.com/hc/en-us/articles/204468593-Service-Disruption-January-21-2015

We apologize for the inconvenience. To contact us for support issues please email support@jbit.com.

We will update this ticket when we know more.
Posted Jan 22, 2015 - 09:57 CST